video_player 1.0.1
video_player: ^1.0.1 copied to clipboard

Flutter Android iOS web

Flutter plugin for displaying inline video with other Flutter widgets on Android, iOS, and web.

702
likes
100 / 110
pub points
99 %
popularity

We analyzed this package on Feb 24, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 72 out of 74 API elements (97.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:video_player/video_player.dart that declares support for platforms: Android, iOS, Web
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
meta^1.0.51.3.0-nullsafety.31.3.0
video_player_platform_interface^2.2.02.2.04.0.0
video_player_web>=0.1.4 <2.0.00.1.4+12.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
collection-1.15.0-nullsafety.31.15.0
flutter_web_plugins-0.0.00.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.2.0` on video_player_platform_interface does not support the latest published version `4.0.0`

pubspec.yaml:20:36

   ╷
20 │   video_player_platform_interface: ^2.2.0
   │                                    ^^^^^^
   ╵
The constraint `>=0.1.4 <2.0.0` on video_player_web does not support the latest published version `2.0.0`

pubspec.yaml:27:21

   ╷
27 │   video_player_web: '>=0.1.4 <2.0.0'
   │                     ^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.

702
likes
100
pub points
99%
popularity

Publisher

flutter.dev

Flutter plugin for displaying inline video with other Flutter widgets on Android, iOS, and web.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

flutter, meta, video_player_platform_interface, video_player_web

More

Packages that depend on video_player